Failed transaction before staking

Hi there,

I had a problem trying to do SOV staking: the staking transaction came back “failed”, but the approval transaction shows up as successful. Should I try again or is there some error message I am missing?

I have seen in another post that a forum member had to transfer amounts less than 8 SOV. In my case it was 6.x, so no problem.

For what it’s worth, the failed transaction is this one: RSK explorer

And the correct approval transaction is: RSK explorer

My wallet balance is still intact. The only special action I did before was to withdraw funds from the liquidity pool (and they were correctly displayed in the wallet). I am using Metamask.

The problem is not exactly from Sovrin application, but I posted here because it happened while doing SOV staking, please let me know if I should post in RSK support.

Maybe the question is too “noob”. In that case, I repeat the operation, right?


I tried it again the same way and it worked.

Good job with the application, anyway!

Could it be related to GAS fees?

Hi @Tao,

I don’t think so because the second time I spent the same amount of gas.

I noticed that during the first attempt it said that the fourth week of liquidity pooling was in progress (it ended on May 11 and it was already the 12th) and during the second attempt it said that the liquidity pool period had already ended. Maybe this had something to do with it. In any case, the second time it worked.

I suggest archiving this thread, but, if you need more data to debug the application, I will be happy to help in any way I can.

1 Like

I tried staking 30 SOV until 2024 and it failed (after trying to send 2 “o” RBTC transactions. I figured Staking 100% of my SOV on hand might be the issue so I tried 75% and it came back insufficient funds (RBTC). I then tried buying more RBTC from BTC in the Liquality wallet and also got insufficient funds. This was odd as it was the same transaction amounts as my first purchase of RBTC when I had 0 RBTC. The Liquality team was looking into it but the automatic 6 hour reversal did not work so I am waiting on the ticket. Just letting folks know as I am not aware of the root cause of the staking issue in the first place.

Update - If Liquality points back to the DAPP I will open a ticket

please use the technical support channel in discord: