FastBTC transaction still has not went through

Can someone please help. I have mentioned this in the discord (cant access the discord now) and in the telegram.

My FastBTC transaction did not go through.

  1. BTC to FastBTC
    BTC Transaction aeb584ead6119292a8a4cc2759954bc0409b1f7ee22171f9687e1802e67a54cb | BlockCypher

2)RSK TXID RSK explorer

I am worried as its been 24 hours and no luck. - I have had no issues sending it before.

I had one that was delayed, clear cache, reload dapp and re-connect wallet and should show up once passed through sovryn system.

1 Like

I was able to get it resolved - just took time =)


I’ve got the same issue.

I sent it to an old deposit address (that had worked fine 4 times previously).

The rBTC is showing in my Top Ups but not in my Sovryn or Liquality wallet.

It’s been 72 hours now.

I’ve tried clearing the cache but that didn’t work.

Any help would be GREATLY appreciated.


if you sent it to the old address, it’s the primary reason why you have not yet seen it in the dapp. please open a ticket at and include your wallet address and a transaction id. This will have to be processed by hand by one of our devs. No worries, your funds are SAFU, but this needs direct attention from a dev to move it across the bridge so it displays in the dapp. From now on, only use freshly generated addresses -it’s one of the optimizations that makes your transaction go through faster, and reliably across the FastBTC bridge node.


Thank you so much for getting back to me.

I’ve raised 4 tickets with support since Sat afternoon and I haven’t gotten a reply. They’re not getting through for some reason.

Have you an email address for them?



can someone help me please. how do i get bitcoin to my metamask account on the rsk network? is that how i start the btc-rbtc process? the wiki vid wasnt helpful and obviously im not understanding the text. i got my wallet connected,got rsk network,but i need to load my meta with btc so i can switch it to rbtc…right? lol…man i hope someone can help,im almost at that point,lol

ok,got it figured out,dont know how i got so lost with that,lol