Problem using Sovryn bridge between BSC and RSK with USDT

I used Sovryn bridge to try to send USDT in BSC to RSK. I followed all the process, the TX in BSC is confirmed (so my USDT are in Bridge SC), but after more than 1h I’m not receiving anything on RSK. I’m using only Metamask so no problem with Liquality address generation…

This is my BSC TX: Binance Transaction Hash (Txhash) Details | BscScan

Please need help

Thanks in advance

I also have problem with BSC to RSK bridge. I sent BNB from BSC smart chain to RSK a day ago and have not seen in my RSK wallet. The tx is confirmed on BSC wallet. I tried again today to see if it is fixed but the problem still exists. If you try to send BNB just send a small amount in case it gets lost. First time I sent 0.1 BNB and second time I sent 0.11 BNB to test the bridge and I can confirm that the bridge is not working

I´m having the same problem with BNB from BSC… Since 3:00am that i used the Bridge, it was confirmed on BSC and nothing from BNB apear on Sovryn… it passed 7 hours…

BSC :Binance Transaction Hash (Txhash) Details | BscScan

Same problem. Sent 0.14 BNB an hour ago
Still no BNB in RSK

I also have problem with BSC to RSK sovryn bridge. I sent this morning 2000 BUSD from BSC to RSK (XUSD) using sovryn bridge and have not seen in my RSK wallet and rsk explorer . The tx is confirmed on BSC wallet. I would like to point out that many other tarnzactions (using sovryn bridge) went smoothly and correctly.
Please help because for me it is a large amount!

Yours faithfully Robert