Lost all my funds today - Liquality wallet

Lost a fortune today because of liquality I always loved sovryn and still do but this experience killed me.
I reinstalled the wallet because of the bug issue.
I have my seed phrase written down on 3 papers at home and wrote it down on paper on extra time before I removed the extension and reinstalled it.
Put in my seed phrase and got a new address tried a 100 times, my life savings are lost.
I’m very sad and disappointed.

Hi Sim,

Nothing is lost there is just some changes with Liquailty. I had to switch to a mobile wallet (use Defiant it’s been great). Load your seed phrase in there and you should see it. I haven’t figured out how to make liquality work again but I’m sure someone will soon.

It looks like the folks at Liquality did an upgrade and the original address that was used for Sovryn is showing in the wallet as legacy rootstock and there is a new address in there that shows as rootstock. When you try and engage the wallet with Sovryn the new address is used instead of the old. That would explain why the funds aren’t showing up. I am in the same boat. I am trying to figure out how to configure Liquality to use the original address. I checked the docs and no updates regarding this issue.

But both my address are new is this the same for you?
I mean I’m very careful with everything that’s why I wrote down me seed phrase so many times.
They are asking me if I’m putting the correct seed phrase, I’m not an idiot I can write down 12 words correctly and save them in a safe place. It’s a fortune I’m losing today.

I have tried with metamask but maybe I will try this later, ty.

I am contacting ‘Liquality’ via their chat. I’ll let you know what they say.


You may have to reinstall the plugin and choose to import existing wallet on initial setup to get it back in there with your seed phrase. I see the did an upgrade yesterday to version 0.41, so who knows what dynamics that presented.

When I reinstalled I pressed import seed, is this what you mean?

Yes that’s correct. Then you should be presented with the blank line matrix to enter your seed words into it and it will have you choose a password for the wallet.

Did this already got a new address with no funds.

Yes you will still get a new address with no funds. However, there should be another rootstock address in your list that coincides with your original one. Make sure you set the Web3 Network to rootstock in ‘settings’.

I get 2 new address no old ones when I do this. I’m soon home will try again. Did this work for you?

Make sure you restart your broswer after you reinstall and restore your old wallet. Once you connect your wallet it should give you the option to connect via the legacy address. I got mine working again by doing that.

I posted it in different topic already, in case you didn’t read it: there was an update and default setting is to show your Rootstock address, which will be empty. You need to change it to “Legacy Rootstock” in the extension, that is your old address with funds.

Nah I did the same, followed the steps. Still rolling a donut.

Liquality shows my leftover RBTC funds within the Legacy Rootstock silo, but does not even recognize SOV the asset as being included in my viewable assets within the extension. Also of note, liquality does not show ANY prior activity history for ANY of my assets. I’m wondering if these issues within Liquality are causing the Sovryn app to read balances as zero? Not sure.

Well, it shows my balances correctly, but, yeah, no transaction history before today. May be the reason that I had to switch from Brave to Chrome in order to use Liquality at all. They messed that update bigly.


Download RWallet if you’re on an iOS device. Import the wallet with the seed phrase of the wallet you use to connect to the Sovryn Dapp. Once connected navigate to your portfolio tab and allow the app to load – funds should be there.

The issue seems to be strictly with Liquality. I hope this helps ease your nerves.

I have tried with different wallets MM, defiant wallet and liquidity now. It seems to be a problem with the derivation path. Don’t know really what to do anymore talked to liquality but I doubt there will be a resolution to this. I was out when I reinstalled so I had to write down the seed phrase at a cafe I was working at. She said maybe it’s the wrong seed so I went home and looked at the papers I had at home exactly the same words. I mean I haven’t done anything wrong had three papers with the seed phrase at home. My nerves are gone.

I don’t get my old address sadly don’t know why anymore. It’s the correct seed seems something is wrong with the derivation path. And I don’t know what to do.

Try importing the seed phrase into another software wallet like metamask.