Problem engaging Liqaulity wallet

I am trying to connect/engage my liquality wallet using chrome. Everytime I click engage wallet, it just opens the download link for the wallet extenson. I have set it as default in the wallet but not sure why it keeps doing it… happens on both machines I use…


  • Did you follow this steps:
    “Make Liquality your default browser wallet and choose the RSK network”
    Preparing to be SOVRYN | Sovryn Wiki

  • Have you disabled all other browser wallets? If you don’t disable the others they can create conflicts

  • If you’ve done that and it still doesn’t work, then clear your browser’s cache and restart it.
    Let me know if you were able to solve the issue.